用户登录

🎉 8 周年订阅优惠

在 VSCode 编辑器上,现在这个 test_driver 目录是红色的,说明它里面包含的文件有一些问题,打开它下面的这个 app_test.dart 文件,这个文件的文件名也是红色的,说明文件里有一些问题。

鼠标放在红色波浪线标记的地方,会出现提示,这里提示 test 这个包不存在。 这样下面用的 test 里的这些方法也就不存在,所以它们的下面也会用红色波浪线标记。

解决这个问题,可以打开项目的 pubspec.yaml 文件。

找到 dev_dependencies,它下面列出的是项目的开发依赖,在它里,可以添加一个 test,然后设置一下需要的版本 ^1.5.1 ,保存一下文件,编辑器自动执行了 flutter pub get 命令,帮我们解决了项目需要的依赖。

完成以后,再回到 app_test.dart 文件,现在这个文件就不会再提示错误了。

Target of URI doesn't exist: 'package:test/test.dart'.《 Flutter 移动应用:测试 》

统计

11371
分钟
0
你学会了
0%
完成

社会化网络

关于

微信订阅号

扫描微信二维码关注宁皓网,每天进步一点