用户登录

在 Dart 的包里面都会包含一个 pubspec.yaml 文件,在这个文件里可以描述一下项目,可以列出这个项目依赖的包等等。 yaml 是一种数据格式,YAML 格式跟 JSON 格式可以互相转换,比起 JSON 格式,这个 YAML 格式写起来更友好一些。

在我们这个项目的根目录下面,可以新建一个文件,名字是 pubspec.yaml。

在这个文件里先添加几个属性描述一下我们这个项目,添加一个 name ,它的值是包的名字,比如 ninghao_dart,再添加一个 description,写一段描述。然后是 version, 说明一下项目的版本号,比如 1.0.0。 homepage 是首页, https://ninghao.net ,再添加一个 environment,在它下面设置一下 sdk,注意这个 sdk 是 environment 里的东西,所以要比 environment 向右缩进两个空格。 用这个 sdk 说明了一下这个项目要求使用的 Dart 版本。

Dart 管理包裹:创建 pubspec.yaml《 Dart 语言:包管理 》

统计

13799
分钟
0
你学会了
0%
完成

社会化网络

关于

微信订阅号

扫描微信二维码关注宁皓网,每天进步一点