用户登录

在演示日期和时间选择的视频里我需要一个额外的包提供的功能 .. 先试着在这个文件里导入需要的这个包 .. package:intl/intl.dart .. 这个包提供了一些国际化的功能 ..

编辑器会提示,说没找到这个包 .. 所以要去安装一下它 .. 项目依赖的一些包,会在 pubspec.yaml 这个文件里面列出来 ..

先找到 dependencies .. 它下面列出的东西就是项目依赖的一些包 .. 拿到一个 Flutter 项目,可能先在项目下面执行一下 flutter packages get 这个命令 .. 它会去给我们安装项目依赖的包 .. 也就是在 dependencies 还是 dev_dependencies 里面列出的东西 ..

这些额外的包,你可以在 pub.dartlang.org 这个网站上找到 .. 搜索一下 intl .. 找到这个包 .. 复制一下它的版本号 ..

再回到 pubspec .. 在 dependencies 这里,添加一个 intl .. 后面加上要使用的版本号 ..

打开调试控制台 .. 然后保存一下这个文件 ..

你会发现,在控制台上会输出,执行了一个 flutter packages get 这个命令 .. 它会给我们安装在 pubspec 里面列出的依赖 ..

如果你的编辑器没有自动执行这个命令 .. 可以使用终端,在项目的下面 .. 手工去执行一下这个命令 ..

再回到这个日期时间的演示文件 .. 你会发现,之前导入这个 intl 包的错误提示就不见了 .. 因为现在我们已经为项目安装了这个包 ...

安装第三方包(演示安装 Intl 包)《 Flutter 移动应用:输入 》

统计

9936
分钟
0
你学会了
0%
完成

社会化网络

关于

微信订阅号

扫描微信二维码关注宁皓网,每天进步一点