用户登录

🎉 8 周年订阅优惠

在终端,执行 flutter doctor ,检查一下 Flutter 的开发环境, 现在会提示有一些 Xcode 相关的问题。比如这里提示说用户要同意 Xcode 许可。

一般在升级了 Xcode 以后可能都需要重新同意一次许可协议,可以在终端,执行这个 sudo xcodebuild 后面加上一个 -license 。

输入当前登录的用户的密码,按空格向后翻页,翻到最后,输入 agree ,表示同意上面的许可协议。

重新再执行 flutter doctor ,这次就不会出现同意 Xcode 许可的问题了。一般这种问题只需要打开 Xcode 就能解决,Xcode 会提示你是否同意许可协议,有时候还会提示我们要安装一下额外的组件,必须要安装这些组件才能正常使用。

最后这里还有一个提示,说没有安装 CocoaPods 这个东西,它是一种依赖管理工具,主要用它管理在苹果的项目里需要的一些依赖。

执行 sudo gem install cocoapods ,安装一下这个东西。

另外官方的文档里,还让我们执行一下 pod setup ,执行 pod setup。

重新运行 flutter doctor,这次我们就基本上解决了所有的关键问题。

解决 Xcode 相关问题《 Flutter 应用案例:起动 》

统计

11440
分钟
0
你学会了
0%
完成

社会化网络

关于

微信订阅号

扫描微信二维码关注宁皓网,每天进步一点