使用 composer 安装 WordPress 插件

0
视频
0
完成
0%
进度
0
分钟
0
完成
0%
进度

🎉 8 周年订阅优惠

使用了 Bedrock 以后,我们就可以使用 Composer 去管理 WordPress 项目了 .. 在 composer.json 里面,已经注册了这个 wpackagist.org .. 它是 WordPress 主题还有插件的一个镜像 .. composer 可以在这里去找到你想要使用的插件还有主题 ...

我现在要去安装一个插件 .. 先进入到项目所在的目录 .. 然后使用 composer require 去安装一个 WordPress 的插件 ..

比如要安装的是 pods 插件 .. 所有的插件还有主题都有一个前缀 .. 就是 wpackagist-plugin .. 一个斜线 分隔一下 .. 然后是插件的名字 .. pods ...

直接执行会去安装最新的插件 .. 如果你想指定一个版本,可以用一个冒号 .. 然后是版本号 .. 我先安装一个以前的版本 .. 比如 2.5.2 .. 一会儿再看一下怎么样去升级插件 ..

回车执行一下 ..

composer require wpackagist-plugin/pods:2.5.2

composer 会去下载这个插件 .. 然后把它放在 composer.json 里面,作为项目的依赖 .. 可以打开这个文件看一下 .. 在 require 这里,会有刚才我们下载的 pods 插件 ..

这样别人得到你的项目以后,执行 composer install ,就去自动下载项目需要的这些东西了 ..

再回到终端 .. 我们可以启用一下这个插件 ... 在我的开发环境里安装了 wp-cli ,所以可以这样 ..

wp plugin activate pods

再查看一下这个插件

wp plugin get pods

注意它现在的版本是 2.5.2 ..

使用 composer 安装 WordPress 插件《 WordPress 日常维护 》

统计

11371
分钟
0
你学会了
0%
完成

社会化网络

关于

微信订阅号

扫描微信二维码关注宁皓网,每天进步一点